Intermittent Outages to Density APIs

Incident Report for Density

Resolved

This incident has been resolved. The majority of historical data from January 23–27 was backfilled by the evening of January 28. We are continuing to run quality checks to ensure data accuracy.

If you have any questions or concerns, please contact your account manager or reach out to support@density.io.
Posted Jan 29, 2026 - 08:00 EST

Monitoring

The outages have been resolved, and we are now processing the remaining data backlog. Live data, APIs, and the setup apps are operating normally.

Historical data from January 23–27 will populate as the backlog clears. No data has been lost.
Posted Jan 27, 2026 - 17:01 EST

Update

Our engineering team continues to make progress toward a resolution. The outages are intermittent and typically last 2–4 minutes. If you encounter an error, please wait a few minutes and refresh the page.

Data access via Atlas, apps, and the API should resume after refresh. Displays may show delayed data.
Posted Jan 27, 2026 - 11:36 EST

Update

Density is continuing to work on a fix for this issue. Outages remain intermittent, with improvements in uptime over the weekend. No data is expected to be lost. Outages continue to affect our APIs, Atlas, apps, and displays.
Posted Jan 26, 2026 - 12:22 EST

Identified

We are currently experiencing intermittent outages affecting all Density APIs. As a result, Atlas and all display types may fail to load.

No data will be lost. The issue has been identified, and our team is actively working to restore full service.
Posted Jan 23, 2026 - 14:50 EST
This incident affected: Atlas (Atlas, Live) and API, Websocket Server, Webhooks.